NowForce Server Issue
Incident Report for NowForce
Resolved
The issue has been resolved. In case you still encounter any issue, please log-out and log back in. In case the issue persist, please contact support@nowforce.com
Posted Jan 13, 2022 - 14:03 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2022 - 13:40 EST
Investigating
We're experiencing an issue with the NowForce system that might cause system slowness.
We are currently looking into the issue and will update soon with more details.
Posted Jan 13, 2022 - 12:38 EST
This incident affected: AWS USA (Dispatcher, API, Dispatch Engine).