NowForce iOS Mobile Applications Crash

Incident Report for NowForce

Resolved

This incident has been resolved.
Posted May 14, 2025 - 14:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 14:13 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 10:55 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 10:52 EDT

Investigating

We are currently experiencing intermittent crashes in the NowForce iOS app for most users.
The crash is caused by a third-party service (AppLanga) used for language translations, which is having intermittent availability.

We are actively reaching out and working with their team to obtain more details and a resolution timeline.
The Android app versions remain unaffected at this time.

We will continue to provide updates as we learn more.
Posted May 14, 2025 - 10:51 EDT
This incident affected: IOS Application.