NowForce Dispatch & Mobile Login Issue

Incident Report for NowForce

Resolved

The issue affecting access to the NowForce dispatch page and mobile app login has been resolved. Services are now operating normally.

Thank you for your patience and understanding throughout this incident.
Posted May 25, 2026 - 09:06 EDT

Investigating

We are currently experiencing an issue with accessing the NowForce dispatch page and logging into the mobile app. Users may be unable to reach the page or sign in at this time. Our team is actively investigating and working to restore normal operation as quickly as possible.

We will provide further updates as soon as more information becomes available.

If you have any questions, please contact support@intellicene.com
Posted May 25, 2026 - 05:13 EDT
This incident affected: AWS USA (Dispatcher, API, Dispatch Engine) and Android Application, IOS Application.