NowForce Dispatcher Issue
Incident Report for NowForce
Resolved
The issue has been resolved. Please contact customer support if you have any further issues.
Posted Nov 13, 2023 - 16:34 EST
Investigating
We are currently experiencing an issue with the NowForce dispatcher that is prohibiting users from generating and regenerating exported PDF incident reports. Our team is currently investing the issue and will update once resolved.
Posted Nov 13, 2023 - 15:56 EST
This incident affected: AWS USA (Dispatcher).