NowForce Dispatcher not accessible for some users
Incident Report for NowForce
Resolved
We have implemented a fix and the system is fully operational again.
Posted almost 2 years ago. Nov 02, 2017 - 07:59 EDT
Identified
We're experiencing some connectivity issues and are currently looking into it.
Posted almost 2 years ago. Nov 02, 2017 - 07:58 EDT