NowForce system issue
Incident Report for NowForce
Resolved
We fixed the servers issue and the system is now fully operational
Posted almost 2 years ago. Jan 03, 2018 - 00:19 EST
Update
We are still working on this issue, we still have no ETA, but we will update as more information becomes available.
Posted almost 2 years ago. Jan 02, 2018 - 23:42 EST
Investigating
We're experiencing an issue with our servers and are currently looking into the issue
Posted almost 2 years ago. Jan 02, 2018 - 22:57 EST