NowForce system issue
Incident Report for NowForce
Resolved
We fixed the servers issue and the system is now fully operational
Posted over 1 year ago. Dec 10, 2017 - 04:55 EST
Investigating
We're experiencing an issue with our servers and are currently looking into the issue.
Posted over 1 year ago. Dec 10, 2017 - 04:44 EST