NowForce Dispatcher not accessible for some users
Incident Report for NowForce
Resolved
The NowForce system is fully operational again on all servers.
Posted about 2 years ago. Aug 28, 2017 - 13:39 EDT
Identified
We restarted one of our servers due to a system error. If you received an error screen when trying to access the system please restart your browser and log back in to the Dispatcher.
Posted about 2 years ago. Aug 28, 2017 - 13:08 EDT