NowForce mobile applications
Incident Report for NowForce
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 16:26 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2022 - 16:22 EDT
Investigating
Our teams are aware of and working on the current issue that is affecting users and their ability to log in to the NowForce mobile applications. Logins are unable to complete and show stuck at processing the EULA screen. More updates will be shared as we work to resolve this issue.
Posted Sep 27, 2022 - 14:16 EDT
This incident affected: Android Application and IOS Application.