NowForce System Issue
Incident Report for NowForce
Resolved
The issue has been resolved, and the system is now fully operational
Posted 12 months ago. Oct 28, 2018 - 00:29 EDT
Investigating
We're experiencing an issue with our servers and are currently looking into the issue.
Posted 12 months ago. Oct 28, 2018 - 00:21 EDT
This incident affected: Dispatcher, API, Auto Disaptch, SMS Gateway, and Email Gateway.